Compare Forked Packages To Gentoo

Revision as of 17:05, September 29, 2013 by Drobbins (Talk | contribs)

Note

This page describes an activity that you can do to help make Funtoo Linux better!

Description

Funtoo Linux has a number of forked packages, and sometimes these packages can get out-of-date relative to Gentoo Linux. Periodically, we need to update ebuilds in Funtoo Linux so that they are current. To make this task easier, we have an automated script that compares versions of forked ebuilds in Funtoo Linux to those in Gentoo Linux.

Here's how it works: Below, you can see a list of all ebuilds in Gentoo Linux that have higher version numbers than those in Funtoo Linux. This list is updated hourly.

Funtoo / Gentoo Comparison (funtoo-current, x86-64bit)

  • app-accessibility/orca 3.14.3 > 3.14.0
  • app-arch/file-roller 3.14.2 > 3.14.1
  • app-dicts/gnome-dictionary 3.14.2 > 3.14.1
  • app-editors/gedit 3.14.2 > 3.14.0
  • app-editors/gedit-plugins 3.14.1 > 3.14.0-r1
  • app-emulation/libvirt-glib 0.2.0 > 0.1.9
  • app-emulation/lxc 1.0.7 > 1.0.6-r1
  • app-misc/bijiben 3.14.2 > 3.14.1
  • app-misc/gnote 3.14.1 > 3.14.0
  • app-misc/tracker 1.2.5 > 1.2.3
  • dev-db/mariadb 10.0.15-r1 > 10.0.14-r1
  • dev-db/mysql 5.6.22 > 5.6.21-r1
  • dev-java/jython 2.7_beta3 > 2.7_beta1-r1
  • dev-lang/tcl 8.6.3 > 8.6.2
  • dev-lang/tk 8.6.3 > 8.6.2
  • dev-libs/boost 1.56.0-r1 > 1.55.0-r1000
  • dev-libs/botan 1.11.8 > 1.10.7-r1000
  • dev-libs/libgit2-glib 0.0.24 > 0.0.22
  • dev-libs/libgweather 3.14.2 > 3.14.1
  • dev-libs/libltdl 2.4.4 > 2.4.3
  • dev-lua/luasec 0.5 > 0.4.1_p20130620
  • dev-python/astroid 1.3.2 > 1.2.1-r1000
  • dev-python/autopep8 1.1 > 1.0.4-r1000
  • dev-python/chameleon 2.18 > 2.15-r1000
  • dev-python/cherrypy 3.3.0 > 3.2.5-r1000
  • dev-python/colander 1.0 > 1.0_beta1-r1000
  • dev-python/dulwich 0.9.8 > 0.9.7-r1000
  • dev-python/eyeD3 0.7.5 > 0.7.4-r1000
  • dev-python/flask-openid 1.2.4 > 1.1.1-r1000
  • dev-python/flask-sqlalchemy 2.0 > 1.0-r1000
  • dev-python/fonttools 2.4 > 2.3-r1000
  • dev-python/foolscap 0.7.0 > 0.6.4-r1000
  • dev-python/ipython 2.3.1 > 1.2.1-r1000
  • dev-python/matplotlib 1.4.2 > 1.3.1-r1000
  • dev-python/meld3 1.0.0 > 0.6.10-r1000
  • dev-python/mwlib 0.15.15 > 0.15.14-r1000
  • dev-python/networkx 1.9.1 > 1.9-r1000
  • dev-python/nevow 0.11.1 > 0.10.0-r1000
  • dev-python/nltk 3.0.0 > 2.0.4-r1000
  • dev-python/nose-exclude 0.2.0 > 0.1.10-r1000
  • dev-python/oauthlib 0.7.2 > 0.6.3-r1000
  • dev-python/pip 6.0.3 > 1.5.6-r1000
  • dev-python/polygon 3.0.7 > 3.0.5-r1000
  • dev-python/pylibmc 1.4.1 > 1.3.0-r1000
  • dev-python/pylint 1.4.0 > 1.3.1-r1000
  • dev-python/pyproj 1.9.3 > 1.9.2-r1000
  • dev-python/pyquery 1.2.9 > 1.2.8-r1000
  • dev-python/pyramid 1.5.2 > 1.4.5
  • dev-python/python-docs 3.4.2 > 3.0.1
  • dev-python/python-ldap 2.4.18 > 2.4.15-r1000
  • dev-python/pyzmq 14.4.1 > 14.3.1-r1000
  • dev-python/reportlab 3.1.44 > 2.7-r1000
  • dev-python/requests 2.5.0-r1 > 2.3.0-r1000
  • dev-python/setuptools 8.2.1 > 7.0-r1000
  • dev-python/sip 4.16.5 > 4.16.4-r1000
  • dev-python/spyder 2.3.2 > 2.3.1-r1000
  • dev-python/sqlalchemy-migrate 0.9.2 > 0.9.1-r1000
  • dev-python/stevedore 1.1.0 > 0.15-r1000
  • dev-python/stomper 0.3.0 > 0.2.8-r1000
  • dev-python/subunit 0.0.21 > 0.0.18-r1000
  • dev-python/tempita 0.5.3 > 0.5.2-r1000
  • dev-python/testtools 1.3.0 > 0.9.35-r1000
  • dev-python/translationstring 1.3 > 1.1-r1000
  • dev-python/twisted-conch 14.0.2 > 13.2.0-r1000
  • dev-python/twisted-core 14.0.2 > 13.2.0-r1000
  • dev-python/twisted-lore 14.0.2 > 13.2.0-r1000
  • dev-python/twisted-mail 14.0.2 > 13.2.0-r1000
  • dev-python/twisted-names 14.0.2 > 13.2.0-r1000
  • dev-python/twisted-news 14.0.2 > 13.2.0-r1000
  • dev-python/twisted-pair 14.0.2 > 13.2.0-r1000
  • dev-python/twisted-runner 14.0.2 > 13.2.0-r1000
  • dev-python/twisted-web 14.0.2 > 13.2.0-r1000
  • dev-python/twisted-words 14.0.2 > 13.2.0-r1000
  • dev-python/unidecode 0.04.17 > 0.04.16-r1000
  • dev-python/urllib3 1.9.1 > 1.8.3-r1000
  • dev-python/urwid 1.2.2 > 1.2.1-r1000
  • dev-python/venusian 1.0 > 1.0_alpha8
  • dev-python/virtualenv 12.0.4 > 1.11.6-r1000
  • dev-python/virtualenvwrapper 4.3.1 > 4.3-r1000
  • dev-python/webtest 2.0.17 > 2.0.15-r1000
  • dev-python/wsgiproxy2 0.4.2 > 0.4.1-r1000
  • dev-python/wtforms 2.0.1 > 1.0.5-r1000
  • dev-python/wxpython 3.0.1.1 > 2.8.12.1
  • dev-python/xhtml2pdf 0.0.6 > 0.0.5-r1000
  • dev-python/xlrd 0.9.3 > 0.9.2-r1000
  • dev-util/boost-build 1.56.0 > 1.55.0-r1000
  • dev-util/eric 5.5.2 > 5.3.8-r1000
  • dev-util/gnome-devel-docs 3.14.3 > 3.14.1
  • dev-vcs/gitg 3.14.1 > 3.14.0
  • games-arcade/gnome-robots 3.14.2 > 3.14.1
  • games-board/four-in-a-row 3.14.2 > 3.14.1
  • games-board/gnome-chess 3.14.2 > 3.14.0
  • games-board/iagno 3.14.2 > 3.14.1
  • games-puzzle/gnome-klotski 3.14.2 > 3.14.1
  • games-puzzle/gnome-sudoku 3.14.2 > 3.14.1
  • gnome-base/gnome-control-center 3.14.2 > 3.14.1-r1
  • gnome-base/gnome-desktop 3.14.2 > 3.14.1
  • gnome-base/gnome-settings-daemon 3.14.2 > 3.14.1-r1
  • gnome-base/gnome-shell 3.14.3 > 3.14.1.5
  • gnome-base/gvfs 1.22.2 > 1.22.1
  • gnome-base/nautilus 3.14.2 > 3.14.0-r2
  • gnome-extra/gnome-boxes 3.14.2 > 3.14.1.2
  • gnome-extra/gnome-color-manager 3.14.2 > 3.14.1-r1
  • gnome-extra/gnome-contacts 3.14.2 > 3.14.1
  • gnome-extra/gnome-documents 3.14.2 > 3.14.1
  • gnome-extra/gnome-shell-extensions 3.14.3 > 3.14.1
  • gnome-extra/gnome-tweak-tool 3.14.2 > 3.14.0
  • gnome-extra/gnome-user-docs 3.14.2 > 3.14.1
  • gnome-extra/gnome-user-share 3.14.2 > 3.14.0
  • gnome-extra/gucharmap 3.14.2 > 3.14.1
  • gnome-extra/nautilus-tracker-tags 1.2.5 > 1.2.3
  • mail-mta/postfix 2.12_pre20141221 > 2.11.3-r1
  • media-gfx/blender 2.72b-r2 > 2.70-r2
  • media-gfx/eog 3.14.3 > 3.14.1
  • media-gfx/eog-plugins 3.14.1 > 3.14.0
  • media-gfx/gnome-photos 3.14.2 > 3.14.0
  • media-sound/gnome-music 3.14.2 > 3.14.1
  • media-video/cheese 3.14.2 > 3.14.1
  • net-firewall/firewalld 0.3.10 > 0.2.12-r1000
  • net-libs/glib-networking 2.42.1 > 2.42.0
  • net-libs/gnome-online-accounts 3.14.2 > 3.14.1
  • net-libs/libsoup 2.48.1 > 2.48.0
  • net-libs/libsoup-gnome 2.48.1 > 2.48.0-r1
  • net-libs/rb_libtorrent 1.0.3 > 1.0.2
  • net-libs/webkit-gtk 2.6.4 > 2.6.1
  • net-misc/gnome-online-miners 3.14.1 > 3.14.0
  • net-misc/networkmanager 0.9.10.1_pre20141101 > 0.9.10.0-r2
  • net-misc/rygel 0.24.2 > 0.24.1
  • net-misc/vinagre 3.14.3 > 3.14.1-r1
  • net-misc/vino 3.14.1 > 3.14.0
  • sci-geosciences/gnome-maps 3.14.2 > 3.14.1.2
  • sys-apps/man-db 2.7.1 > 2.7.0.2
  • sys-apps/pciutils 3.3.0 > 3.2.1
  • sys-devel/make 4.1-r1 > 3.82-r4
  • sys-libs/db 6.1.19 > 6.0.30-r2
  • sys-libs/libselinux 2.4_rc7 > 2.3-r1001
  • sys-libs/libsemanage 2.4_rc7 > 2.3-r1000
  • www-client/epiphany 3.14.2 > 3.14.1
  • www-servers/tornado 4.0.2 > 3.2.2-r1000
  • x11-base/xorg-server 1.16.2.901-r1 > 1.16.2-r1
  • x11-drivers/ati-drivers 14.12 > 14.9-r1
  • x11-misc/notification-daemon 3.14.1 > 3.14.0
  • x11-terms/gnome-terminal 3.14.2 > 3.14.1-r2
  • x11-themes/gnome-themes-standard 3.14.2.3 > 3.14.0
  • x11-wm/mutter 3.14.3 > 3.14.1.5

Some of these ebuilds may be intentionally kept at earlier versions, although in general, we want to update ebuilds to the most recent version that works reliably. Here are some technical caveats:

  • Rev parts of ebuilds ("-rX") are not considered in version comparisons, since sometimes Gentoo and Funtoo revisions are not analogous.
  • Masks are not used for this version comparison. The latest unmasked or masked version in Gentoo is compared against the latest masked or unmasked version in Funtoo.

How To Help

Here's how you can help: If you see an package above that appears to be out-of-date, and you believe we should update to a newer version, open a bug on the Funtoo bug tracker. We can look into the ebuild and will give you feedback on whether we feel a new version of the ebuild should be added.

If there is some consensus that it should be updated, then generally Funtoo staff will update the ebuild for you, since generally we are familiar with why the ebuild was forked and be able to efficiently update the package to the most recent version.

However, in some cases it may be possible for you can also help with the update process, if you are so inclined, by forking the funtoo-overlay on GitHub and working on updating the ebuild yourself. Reference your commits in a bug report on our bug tracker. If you are going to help with ebuild writing, it's important to first familiarize yourself with why we forked the ebuild in the first place. The best way to dig up information on the history of the forked Funtoo package is to type "git log ." in the ebuild directory. This will show log information for the package only, and you can look at the history of the ebuild.

When updating ebuilds, we do want to look at Gentoo's most recent changes. Some of our ebuilds are mild variations of Gentoo's ebuilds, while others are complete rewrites. In general, we like to make our work as easy as possible, so we don't want to duplicate work, although sometimes there are exceptions where we will rewrite complex core ebuilds to make them more maintainable and easy to understand (our sys-devel/gcc ebuilds are an example of this.)

Of course, there's a reason we originally forked an ebuild, and we want to make the process of updating ebuilds as easy as possible. Sometimes, we will fork a package from Gentoo for a specific reason, such as a build breakage, and once the issue is resolved upstream, we will want to unfork the package by removing it from funtoo-overlay entirely. In general, we want to minimize the number of forked ebuilds to the minimum number necessary.