Difference between pages "Package:Libgcrypt" and "Package:Libgcrypt (Compatibility Libraries)"

(Difference between pages)
m (Drobbins moved page Libgcrypt to Package:Libgcrypt without leaving a redirect)
 
m (Drobbins moved page Libgcrypt (Compatibility Libraries) to Package:Libgcrypt (Compatibility Libraries) without leaving a redirect)
 
Line 1: Line 1:
 
{{Ebuild
 
{{Ebuild
|Summary=Libgcrypt is a general-purpose cryptographic library.
+
|Summary=Libgcrypt is a general purpose cryptographic library. This version of Libgcrypt is is designed to sit alongside an existing libgcrypt install, and just provide compatibility libs for apps that require an older libgcrypt.
|CatPkg=dev-libs/libgcrypt
+
 
 +
|CatPkg=dev-libs/libgcrypt-compat
 
|Maintainer=Drobbins,  
 
|Maintainer=Drobbins,  
 
|Repository=Funtoo Overlay
 
|Repository=Funtoo Overlay
 
}}
 
}}
This ebuild has been forked from Gentoo Linux, primarily to implement the [[Package:Libgcrypt (Compatibility Libraries)|libgcrypt-compat ebuild]]. There was an ABI change between libgcrypt 1.5 and 1.6, meaning apps written for one may not work with the other.
+
This ebuild was added to Funtoo Linux to serve as a compatibility library for binary ebuilds that require an older version of libgcrypt.  
 
+
Gentoo has an older version of libgcrypt that just installs a compatibility library, and uses a sub-slot to differentiate between the two.
+
  
I thought it best to have a separate ebuild called libgcrypt-compat for providing older versions of the libgcrypt shared library, and nothing else, specificially indended for binary package compatibility. Details can be found in {{Bug|FL-1145}}.
+
This ebuild is designed to install alongside the newer libgcrypt ebuild, providing the older shared libraries only, but no headers, and is designed not to touch the main .so symlink. This way, binary packages can find and use this library just fine, but from-source ebuilds will continue to use libgcrypt.
 
{{EbuildFooter}}
 
{{EbuildFooter}}

Latest revision as of 20:01, June 19, 2014

dev-libs/libgcrypt-compat


Current Maintainer(s):Daniel Robbins
Source Repository:Funtoo Overlay

Summary: Libgcrypt is a general purpose cryptographic library. This version of Libgcrypt is is designed to sit alongside an existing libgcrypt install, and just provide compatibility libs for apps that require an older libgcrypt.


News

Drobbins

New Media Mix-ins

Funtoo Linux now has new media mix-ins. Learn about them and how to use them.
11 January 2015 by Drobbins
Drobbins

The Many Builds of Funtoo Linux

We now have lots of different builds of Funtoo Linux for various CPUs, as well as Hardened, Stable and ARM, and a new UI to browse them. Learn more here.
25 December 2014 by Drobbins
Oleg

Python Updater Deprecation

Python-updater is no longer part of Funtoo Linux.
6 December 2014 by Oleg
View More News...

Libgcrypt (Compatibility Libraries)

Tip

This is a wiki page. To edit it, Create a Funtoo account. Then log in and then click here to edit this page. See our editing guidelines to becoming a wiki-editing pro.

This ebuild was added to Funtoo Linux to serve as a compatibility library for binary ebuilds that require an older version of libgcrypt.

This ebuild is designed to install alongside the newer libgcrypt ebuild, providing the older shared libraries only, but no headers, and is designed not to touch the main .so symlink. This way, binary packages can find and use this library just fine, but from-source ebuilds will continue to use libgcrypt.