Difference between pages "Subarches" and "Emerge"

(Difference between pages)
(core2_64)
 
m (Undo revision 8974 by Tocadotux (talk) not under pt-br names)
 
Line 1: Line 1:
{{:Install/Header}}
+
== Getting started with emerge ==
= Funtoo Linux Sub-Architectures =
+
Emerge is the front-end for funtoo's Portage package manager. With emerge it is easy to install, update or remove packages.
__NOTITLE__
+
This page provides an overview of Funtoo Linux sub-architectures (also called ''subarches'',) designed for quick and easy reference. While this information is available in other places, such as Wikipedia, it often takes some time to study and cross-reference the various articles to get a good understanding of each type of sub-architecture, and this information generally isn't all collected neatly in one place. That is the purpose of this page. When possible, links to more detailed Wikipedia pages are provided. You are encouraged to help maintain this page as well as the Wikipedia articles referenced here.
+
  
== 64-bit Suport (Generic) ==
+
=== Update Package Database ===
 +
'''Sync local package database. This will update your local Portage tree with the latest Funtoo ebuilds.'''
 +
<console>
 +
###i## emerge --sync
 +
</console>
  
=== generic_64 ===
+
=== Search packages ===
 +
'''Search packages by name.'''
 +
<console>
 +
###i## emerge -s firefox
 +
###i## emerge --search firefox
 +
</console>
  
The '''generic_64''' subarch is designed to support 64-bit PC-compatible CPUs, such as the [[Wikipedia:AMD_K8|AMD K8-series processors]], which were introduced in late 2003. They were notable as the first processors that supported the [[Wikipedia:X86-64|AMD64 (also called X86-64) 64-bit instruction set]] for PC-compatible systems, which was introduced as a backwards-compatible 64-bit alternative to Intel's IA-64 architecture. Intel followed suit and also began supporting this 64-bit instruction set, which they called "[[Wikipedia:X86-64#Intel_64|Intel 64]]", by releasing X86-64 64-bit compatible CPUs from mid-2004 onwards (See [[Wikipedia:X86-64#Intel_64_implementations|Intel 64 implementations]].)
+
'''Search packages by description.'''
 +
<console>
 +
###i## emerge -S web browser
 +
###i## emerge --searchdesc web browser
 +
</console>
  
AMD desktop 64-bit CPUs include the Athlon 64, Athlon 64 FX, Athlon 64 X2, Athlon X2, Turion 64, Turion 64 X2 and Sempron series processors. AMD server processors were released under the Opteron brand and have codenames SledgeHammer, Venus, Troy, Athens, Denmark, Italy, Egypt, Santa Ana and Santa Rosa. All Opterons released through late 2006 were based on the K8 microarchitecture with original X86-64 instructions.
+
=== Install packages ===
 +
'''Install package.'''
 +
<console>
 +
###i## emerge firefox
 +
</console>
  
== 64-bit AMD Processors ==
+
'''Install multiple packages.'''
 +
<console>
 +
###i## emerge firefox thunderbird
 +
</console>
  
=== amd64-k10 ===
+
'''Install package. Ask for confirmation before performing any changes. Show verbose output.'''
 +
<console>
 +
###i## emerge -av firefox
 +
###i## emerge --ask firefox
 +
</console>
  
The '''amd64-k10''' subarch provides support for the [[Wikipedia:AMD_10h|AMD Family 10h processors]], which were released in late 2007 as a successor to the AMD K8 series processors.
+
=== Remove packages ===
 +
'''Remove package.'''
 +
<console>
 +
###i## emerge -C firefox
 +
###i## emerge --unmerge firefox
 +
</console>
  
Desktop amd64-k10 CPUs include [[Wikipedia:AMD Phenom|AMD Phenom]], [[Wikipedia:AMD_10h#Phenom_II_Models|AMD Phenom II]] and [[Wikipedia:AMD_10h#Athlon_II_Models|AMD Athlon II]]. Server CPUs include Opterons with codenames Budapest, Barcelona, Suzuka, Shanghai, Istanbul, Lisbon, and Magny-Cours. A full listing of amd64-k10 Opteron models [[Wikipedia:List_of_AMD_Opteron_microprocessors#K10_based_Opterons|can be found here]].
+
'''Remove package. Ask for confirmation before performing any changes.'''
 +
<console>
 +
###i## emerge -aC firefox
 +
</console>
  
=== amd64-bulldozer ===
+
'''Remove orphaned packages. Ask for confirmation before performing any changes.'''
 +
<console>
 +
###i## emerge -a --depclean
 +
</console>
  
The '''amd64-bulldozer''' subarch supports the [[Wikipedia:Bulldozer (microarchitecture)|AMD bulldozer microarchitecture]] CPUs, which were released from late 2011 through the first quarter of 2012 as a replacement for the [[Wikipedia:AMD_10h|K10 microarchitecture]] CPUs.
+
=== Update packages ===
Bulldozer desktop CPUs use the [[Wikipedia:Socket_AM3+|AM3+ socket]] and server CPUs use the  [[Wikipedia:Socket_G34|G34 socket]].
+
'''Update all packages.'''
 +
<console>
 +
###i## emerge -uDN @world
 +
</console>
  
Desktop bulldozer CPUs include the [[Wikipedia:List_of_AMD_FX_microprocessors#.22Zambezi.22_.2832_nm_SOI.29|Zambezi FX-series CPUs]]. Server bulldozer CPUs include Opterons with codenames Zurich (Opteron 3200-series), Valencia (Opteron 4200-series) and Interlagos (Opteron 6200 series). A complete list of Opteron models [[Wikipedia:http://en.wikipedia.org/wiki/Opteron#Opteron_.2832_nm_SOI.29-_First_Generation_Bulldozer_Microarchitecture|can be found here.]].
+
'''Update all packages. Ask for confirmation before performing any changes. Show verbose output.'''
 +
<console>
 +
###i## emerge -uavDN @world
 +
</console>
  
=== amd64-piledriver ===
+
'''When upgrading to a new version of perl, it is necessary to also run <code>perl-cleaner</code> afterwards:'''
 +
<console>
 +
###i## emerge -auvDN @world
 +
###i## perl-cleaner --all
 +
</console>
  
The '''amd64-piledriver''' subarch supports the [[Wikipedia:Piledriver (microarchitecture)|AMD Piledriver microarchitecture]] produced by AMD from mid-2012 through 2015, which is the successor to the [[Wikipedia:Bulldozer (microarchitecture)|AMD bulldozer microarchitecture]].  
+
{{Note|This requirement of running <code>perl-cleaner</code> will eventually go away, once all perl-related ebuilds are updated to EAPI 5. EAPI 5 is a version of the Ebuild specification that supports smart updating of perl-related bits.}}
Piledriver CPUs and APUs are available that use the [[Wikipedia:FM2 Socket|FM2 socket]]. Desktop Piledriver CPUs use the [[Wikipedia:Socket_AM3+|AM3+ socket]]. Server Piledriver CPUs use a variety of sockets, including [[Wikipedia:Socket_AM3+|AM3+]], [[Wikipedia:Socket_C32|C32]] and [[Wikipedia:Socket_G34|G34]].
+
  
Desktop piledriver CPU and APUs include FX-series with codename Vishera (FX-8350, FX-8370),  [[Wikipedia:List_of_AMD_accelerated_processing_unit_microprocessors#Virgo:_.22Trinity.22_.282012.2C_32_nm.29|A-series with codename Trinity]] (A6-5400K, A10-5800K) and [[Wikipedia:http://en.wikipedia.org/wiki/List_of_AMD_accelerated_processing_unit_microprocessors#.22Richland.22_.282013.2C_32_nm.29_2|A-series with codename Richland]].
+
== Emerge options ==
  
Server piledriver CPUs include Opterons with codenames Delhi (Opteron 3300-series, [[Wikipedia:Socket_AM3+|AM3+]]), Seoul (Opteron 4300-series, [[Wikipedia:Socket_C32|C32]])  and Abu Dhabi (Opteron 6300-series, [[Wikipedia:Socket_G34|G34]]). A full listing of Opteron models [[Wikipedia:Opteron#Opteron_.2832_nm_SOI.29_-_Piledriver_Microarchitecture|is available here]].
+
; --sync
 +
: Updates the portage tree that is located in /usr/portage by default.
  
Piledriver adds several new instructions over bulldozer, so AMD bulldozer systems cannot run amd64-piledriver-optimized stages. However, this subarch is  instruction-compatible with its successor, the, so amd64-piledriver stages can run on amd64-steamroller systems, and vice versa.
+
; --search -s
 +
: Searches  for  matches  of  the supplied  string in the portage tree.
  
=== amd64-steamroller ===
+
; --searchdesc -S
 +
: Matches the search string against the description field as well as the package name.
  
The '''amd64-steamroller''' subarch supports the  [[Wikipedia:Steamroller (microarchitecture)|AMD steamroller microarchitecture]], produced from early 2014. It is the successor to the [[Wikipedia:Piledriver (microarchitecture)|AMD Piledriver microarchitecture]].
+
; --ask -a
Steamroller APUs are available that use the [[Wikipedia:FM2+ Socket|FM2+ socket]] and  [[Wikipedia:Socket_FP3|FP3 socket]] (mobile.)
+
: Ask for confirmation before performing any changes.
  
Desktop steamroller APUs include the [[Wikipedia:AMD_Accelerated_Processing_Unit#Steamroller_architecture_.282014.29:_Kaveri|A-Series with codename Kaveri]], such as the quad-core AMD A10-7850K APU. Steamroller APUs are also available in mobile versions. Server steamroller APUs will include the codename Berlin APUs, which are expected to be released some time in 2015.
+
; --pretend -p
 +
: Instead of actually performing the merge, simply display what *would* have been installed if --pretend weren't used.
  
Amd64-steamroller subarches are instruction-compatible with amd64-piledriver, but add new instructions over amd64-bulldozer.
+
; --unmerge -C
 +
: Removes all matching packages.
  
=== amd64-jaguar ===
+
; --update -u
 +
: Updates  packages to the best version available, which may not always be the  highest version number due to masking for testing and development.
  
The '''amd64-jaguar''' (also called AMD Family 16h) subarch supports the  [[Wikipedia:Jaguar (microarchitecture)|AMD jaguar microarchitecture]], which is targeted at low-power devices, including notebooks, tablets and small form-factor desktops and servers. It is perhaps most well-known for being the microarchitecture used for the [[Wikipedia:Playstation 4|Playstation 4]] and [[Wikipedia:Xbox One|Xbox One]], which each use custom 8-core Jaguar APUs.
+
; --deep [DEPTH] -D
Socketed Jaguar APUs use the [[Wikipedia:AM1 Socket|AM1 socket]], and  [[Wikipedia:Socket_FT3|FT3 socket]] for mobile devices. G-series [[Wikipedia:System_on_a_chip|"system on a chip" (SoC)]] APUs are available for non-socketed devices such as tablets and embedded system boards.
+
: force  emerge  to  consider  the entire  dependency tree of packages, instead of checking only the immediate dependencies of the packages.
  
Desktop Jaguar APUs include the [[Wikipedia:List_of_AMD_accelerated_processing_unit_microprocessors#.22Kabini.22.2C_.22Temash.22_.282013.2C_28_nm.29|Kabini A-series APUs and Temash E-series APUs]], such as the Athlon 5150 and 5350 APUs, and Sempron 2650 and 3850.
+
; --newuse -N
 +
: Tells emerge to include installed packages where USE flags have changed since compilation.
  
Amd64-jaguar subarches use the MOVBE instruction which is not available on amd64-bulldozer, amd64-piledriver or amd64-steamroller. They are thus not instruction-compatible with any of these subarches.
+
; --depclean -c
 +
: Remove orphaned packages. Cleans the system by removing packages that are not associated with explicitly merged packages.
  
== 64-bit intel Processors ==
+
; --autounmask-write
* [[Wikipedia:Intel_Core|intel core processors]]
+
: Automatically write package.use settings as necessary to satisfy dependencies.
* [[Wikipedia:Comparison_of_Intel_processors|comparison of intel processors]]
+
  
=== corei7 ===
+
; --resume -r
<console>
+
: Resumes  the  most recent merge list that has been aborted due to an error.
CFLAGS: -march=corei7 -O2 -pipe
+
CHOST: x86_64-pc-linux-gnu
+
USE: mmx sse sse2 sse3 ssse3 sse4
+
</console>
+
Intel Core i7 CPU with 64-bit extensions, MMX, SSE, SSE2, SSE3, SSSE3, SSE4.1 and SSE4.2 instruction set support.  
+
  
Introduced November of 2008, the '''corei7''' subarch supports the [[Wikipedia:Nehalem_(microarchitecture)|Nehalem microarchitecture]], [[Wikipedia:Sandy_Bridge_(microarchitecture)|Sandy Bridge microarchitecture]], [[Wikipedia:Ivy_Bridge_(microarchitecture)|Ivy Bridge microarchitecture]], and [[Wikipedia:Haswell_(microarchitecture)|Haswell microarchitecture]].
+
; --jobs[=JOBS] -j [JOBS]
 +
: Specifies the number of packages to build simultaneously.
  
=== core2_64 ===
+
; --load-average [LOAD]
<console>
+
: Specifies  that  no  new  builds should be started if there are other builds running and the load average is at least LOAD (a floating-point number).
CFLAGS: -march=core2 -O2 -pipe
+
CHOST: x86_64-pc-linux-gnu
+
HOSTUSE: mmx sse sse2 sse3 ssse3
+
</console>
+
  
Intel Core 2 CPU with 64-bit extensions, MMX, SSE, SSE2, SSE3 and SSSE3 instruction set support.  
+
== Configuration ==
 +
=== make.conf ===
 +
Emerge can be configured by editing
  
The '''core2_64''' subarch supports 64-bit-capable [[Wikipedia:Intel_Core_2|Intel Core 2 Processors]], which includes ''some'' processors of the [[Wikipedia:Intel Core (microarchitecture)|Core]] and all processors of the [[Wikipedia:Penryn_(microarchitecture)|Penryn]] microarchitecture. All "Core 2" branded processors are 64-bit-capable. These processors were introduced in July of 2006 and were phased out in July of 2011, in favor of  [[Wikipedia:Nehalem_(microarchitecture)|Nehalem-based]] processors.
+
{{file|name=/etc/portage/make.conf||desc=See [[Make.conf]]|body=
 +
CFLAGS="-march=native -O2 -pipe"
 +
CXXFLAGS="-march=native -O2 -pipe"
  
For a full list of 64-bit capable Core 2 processors, [http://ark.intel.com/search/advanced?s=t&FamilyText=Legacy%20Intel%C2%AE%20Core%E2%84%A22%20Processor&InstructionSet=64-bit see this link].
+
MAKEOPTS="-j2"
 +
EMERGE_DEFAULT_OPTS="--jobs 2 --load-average 2"
 +
INPUT_DEVICES="evdev synaptics"
 +
VIDEO_CARDS="intel i965"
 +
LINGUAS="en en_US en_GB"
 +
ACCEPT_LICENSE="*"
  
The 64-bit capable ''Core 2''-branded CPUs include: "Conroe"/"Allendale" (dual-core for desktops), "Merom" (dual-core for laptops), "Merom-L" (single-core for laptops), "Kentsfield" (quad-core for desktops), and the updated variants named "Wolfdale" (dual-core for desktops), "Penryn" (dual-core for laptops),  and "Yorkfield" (quad-core for desktops). (Note: ''For the server and workstation "Woodcrest", "Tigerton", "Harpertown" and "Dunnington" CPUs see the [[Wikipedia:Xeon|Xeon]] brand''.)
+
USE="mmx mmxext sse sse2 sse3 ssse3 threads alsa X gtk xcb dri opengl vaapi udev \
 +
    svg x264 xvid gstreamer webm vpx icu bash-completion vim-pager \
 +
    -gnome -xscreensaver -cups -fortran -deprecated -iptables -ipv6 -geoloc \
 +
    -mta -sendmail -kmod -tiff -live -quicktime -real -gpm -themes"
 +
}}
  
=== atom_64 ===
+
=== Package.use ===
 +
Per-package use flags can be configured in
  
The Intel Atom Processor is the common name for Intel's  [[Wikipedia:Bonnell_(microarchitecture)|Bonnell microarchitecture]],  which represents a partial revival of the principles used in earlier Intel designs such as P5 and the i486, with the sole purpose of enhancing the performance per watt ratio. Successor to the [[Wikipedia:Stealey_(microprocessor)|Intel A100 series (Stealey)]], which was derived from the [[Wikipedia:Pentium_M|Pentium M]], the Intel Atom has been produced since 2008. Targeted at low-power devices, Atom processors can be found in a wide range of notebooks, tablets and small form-factor desktops and servers.
+
{{file|name=/etc/portage/package.use|body=
 +
x11-wm/dwm savedconfig
 +
x11-drivers/ati-drivers qt4
 +
media-sound/ncmpcpp visualizer clock taglib
 +
}}
  
The '''atom_64''' sub-architecture supports 64-bit capable Intel Atom CPUs. The first 64-bit capable Intel Atom CPUs were the Intel Atom 230 and 330, released in late 2008. However, Intel also continued to produce new 32-bit Atom Processors after this date. For example, the Atom N2xx series Atom Diamondville models cannot support 64-bit operation, while the 2xx and 3xx Diamondville, Pineview, Cedarview and Centerton can. A full list of 64-bit capable Intel Atom Processors [http://ark.intel.com/search/advanced?s=t&FamilyText=Intel%C2%AE%20Atom%E2%84%A2%20Processor&InstructionSet=64-bit can be seen here.]
+
=== package.accept_keywords ===
 
+
If you want to install a package that has not been tested on your architecture you need to edit
{{Important|For 64-bit support to be functional, a 64-bit capable Atom Processor must be paired ''with a processor, chipset, and BIOS'' that all support [[Wikipedia:X86-64#Intel_64|Intel 64]]. If not all hardware supports 64-bit, then you must use the [[subarches#atom_32|atom_32]] subarch instead.}}
+
{{file|name=/etc/portage/package.accept_keywords|body=
 
+
=app-misc/screenfetch-9999 **
== 32-bit Suport (Generic) ==
+
}}
=== generic_32 ===
+
 
+
== 32-bit AMD Processors ==
+
=== amd64-k8_32 ===
+
=== athlon-xp ===
+
 
+
== 32-bit ARM Processors ==
+
=== armv5te ===
+
=== armv6j_hardfp ===
+
=== armv7a_hardfp ===
+
 
+
== 32-bit Intel Processors ==
+
=== atom_32 ===
+
=== core2_32 ===
+
=== i686 ===
+
=== pentium4 ===
+
  
 +
== Other Resources ==
 +
For more info see the emerge man page.
 +
<console>
 +
$##i## man emerge
 +
</console>
  
{{:Install/Footer}}
+
[[Category:Portage]]
 +
[[Category:HOWTO]]
 +
[[Category:Tutorial]]
 +
[[Category:System]]
 +
[[Category:First Steps]]

Latest revision as of 16:03, February 7, 2015

Getting started with emerge

Emerge is the front-end for funtoo's Portage package manager. With emerge it is easy to install, update or remove packages.

Update Package Database

Sync local package database. This will update your local Portage tree with the latest Funtoo ebuilds.

# emerge --sync

Search packages

Search packages by name.

# emerge -s firefox
# emerge --search firefox

Search packages by description.

# emerge -S web browser
# emerge --searchdesc web browser

Install packages

Install package.

# emerge firefox

Install multiple packages.

# emerge firefox thunderbird

Install package. Ask for confirmation before performing any changes. Show verbose output.

# emerge -av firefox
# emerge --ask firefox

Remove packages

Remove package.

# emerge -C firefox
# emerge --unmerge firefox

Remove package. Ask for confirmation before performing any changes.

# emerge -aC firefox

Remove orphaned packages. Ask for confirmation before performing any changes.

# emerge -a --depclean

Update packages

Update all packages.

# emerge -uDN @world

Update all packages. Ask for confirmation before performing any changes. Show verbose output.

# emerge -uavDN @world

When upgrading to a new version of perl, it is necessary to also run perl-cleaner afterwards:

# emerge -auvDN @world
# perl-cleaner --all
Note

This requirement of running perl-cleaner will eventually go away, once all perl-related ebuilds are updated to EAPI 5. EAPI 5 is a version of the Ebuild specification that supports smart updating of perl-related bits.

Emerge options

--sync
Updates the portage tree that is located in /usr/portage by default.
--search -s
Searches for matches of the supplied string in the portage tree.
--searchdesc -S
Matches the search string against the description field as well as the package name.
--ask -a
Ask for confirmation before performing any changes.
--pretend -p
Instead of actually performing the merge, simply display what *would* have been installed if --pretend weren't used.
--unmerge -C
Removes all matching packages.
--update -u
Updates packages to the best version available, which may not always be the highest version number due to masking for testing and development.
--deep [DEPTH] -D
force emerge to consider the entire dependency tree of packages, instead of checking only the immediate dependencies of the packages.
--newuse -N
Tells emerge to include installed packages where USE flags have changed since compilation.
--depclean -c
Remove orphaned packages. Cleans the system by removing packages that are not associated with explicitly merged packages.
--autounmask-write
Automatically write package.use settings as necessary to satisfy dependencies.
--resume -r
Resumes the most recent merge list that has been aborted due to an error.
--jobs[=JOBS] -j [JOBS]
Specifies the number of packages to build simultaneously.
--load-average [LOAD]
Specifies that no new builds should be started if there are other builds running and the load average is at least LOAD (a floating-point number).

Configuration

make.conf

Emerge can be configured by editing

/etc/portage/make.conf - See Make.conf
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="-march=native -O2 -pipe"

MAKEOPTS="-j2"
EMERGE_DEFAULT_OPTS="--jobs 2 --load-average 2"
INPUT_DEVICES="evdev synaptics"
VIDEO_CARDS="intel i965"
LINGUAS="en en_US en_GB"
ACCEPT_LICENSE="*"

USE="mmx mmxext sse sse2 sse3 ssse3 threads alsa X gtk xcb dri opengl vaapi udev \
     svg x264 xvid gstreamer webm vpx icu bash-completion vim-pager \
     -gnome -xscreensaver -cups -fortran -deprecated -iptables -ipv6 -geoloc \
     -mta -sendmail -kmod -tiff -live -quicktime -real -gpm -themes"

Package.use

Per-package use flags can be configured in

/etc/portage/package.use
x11-wm/dwm savedconfig
x11-drivers/ati-drivers qt4
media-sound/ncmpcpp visualizer clock taglib

package.accept_keywords

If you want to install a package that has not been tested on your architecture you need to edit

/etc/portage/package.accept_keywords
=app-misc/screenfetch-9999 **

Other Resources

For more info see the emerge man page.

$ man emerge