News:Testing GNOME 3.14

Revision as of 06:33, October 24, 2014 by Dantrell (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Testing GNOME 3.14

GNOME 3.14 is now available in Funtoo, masked for testing. Help us test it!

By Dantrell / October 22, 2014

Note

This is a News item page, and you can comment using DISQUS at the bottom.

GNOME 3.14 is now available in Funtoo, masked for testing. Please help us test it. If you find bugs, or want more detailed information on what is included, please see FL-1637.

Preparing

sync

First, sync the tree if you haven't recently as you need access to a file in the tree:

# emerge --sync

unmask

Now, reverse the GNOME 3.14 mask file:

package.mask (directory)

# cd /etc/portage/package.unmask
# ln -s /usr/portage/profiles/package.mask/funtoo-gnome .

package.mask (file)

# cat /usr/portage/profiles/package.mask/funtoo-gnome >> /etc/portage/package.unmask

USE flags

Then to simplify matters, enable the gnome mix-in:

# eselect profile list
Currently available mix-ins profiles:  
  [11]  funtoo/1.0/linux-gnu/mix-ins/audio
  [12]  funtoo/1.0/linux-gnu/mix-ins/cinnamon
  [13]  funtoo/1.0/linux-gnu/mix-ins/console-extras
  [14]  funtoo/1.0/linux-gnu/mix-ins/dvd
  [15]  funtoo/1.0/linux-gnu/mix-ins/gnome
  [16]  funtoo/1.0/linux-gnu/mix-ins/kde
  [17]  funtoo/1.0/linux-gnu/mix-ins/mate
  [18]  funtoo/1.0/linux-gnu/mix-ins/media
  [19]  funtoo/1.0/linux-gnu/mix-ins/print
  [20]  funtoo/1.0/linux-gnu/mix-ins/python3-only
  [21]  funtoo/1.0/linux-gnu/mix-ins/rhel5-compat
  [22]  funtoo/1.0/linux-gnu/mix-ins/server-db
  [23]  funtoo/1.0/linux-gnu/mix-ins/server-mail
  [24]  funtoo/1.0/linux-gnu/mix-ins/server-web
  [25]  funtoo/1.0/linux-gnu/mix-ins/X
  [26]  funtoo/1.0/linux-gnu/mix-ins/xfce
  [27]  funtoo/1.0/linux-gnu/mix-ins/vmware-guest
  [28]  funtoo/1.0/linux-gnu/mix-ins/hardened
# eselect profile add funtoo/1.0/linux-gnu/mix-ins/gnome

Emerging

Installing GNOME 3.14

gnome

To emerge gnome run the following command:

# emerge gnome
gnome-light

To emerge gnome-light run the following command:

# emerge gnome-light

Upgrading from GNOME 3.12

To update "gnome" or "gnome-light" run the following command:

# emerge -vauDN world

blog comments powered by Disqus