Ports-2012-to-kits-migration-guide

Intro

In this guide we try to cover the migration from an older Funtoo portage tree, known as ports-2012, to a new kits based tree, called meta-repo.

Current builds migration

For current builds, aka "unstable keyworded" boxes, it is as easy as explained in meta-repo's README: https://github.com/funtoo/meta-repo/blob/master/README.rst

Notice, after emerge -auDN @world you may see a various ebuilds updates and downgrades. This is expected. With update, a newer version of ego provided. It includes a new module called "sync" which performs updates of the meta-repo. Because of meta-repo's unique structure, portage has no ability to sync with the usual emerge --sync. It may provide support for this in the future. To update just run:

# ego sync

Stable build migration

As you may notice, funtoo-stable builds are now retired -- see http://www.funtoo.org/News:Funtoo-Stable_Going_Away. It is recommended to upgrade to current builds. If you feel that doing so is not an option, or your boxes do not allow to receive such an update, like if they are in production, you may skip this step as the funtoo stable profile is still working. However, you may notice various emerge warnings or dependency problems.

Updating build

This is a one-line command performed by epro

#  epro build current

Upgrade

This can be a tricky part as updating from stable to unstable keywords may result in various portage conflicts. Hopefully, it will be smooth.

#  emerge -auND @world --newrepo

if you get slots conflicts similar to the ones shown below:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:
sys-libs/ncurses:0

  (sys-libs/ncurses-6.0-r1:0/6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-libs/ncurses-5.9-r5:0/5::gentoo, installed) pulled in by
    >=sys-libs/ncurses-5.2-r2:0/5= required by (app-editors/vim-8.0.0606:0/0::gentoo, installed)
                             ^^^^^

try using a more advance update command, for example:

#  emerge -auDN @world --with-bdeps=y --verbose-conflicts --backtrack=30

Important core packages updates

There will be at least 2 important ebuilds updates which required the user's attention, sys-libs/ncurses-6* and dev-lang/perl-5.24*. After update as shown in the above command, it is necessary to rebuild many ebuilds. That is so because ncurses-6 is incompatible with ncurses-5. During the update, portage will rebuild most of the ebuilds. To complete the update, perform the following check:

#  oleg / # revdep-rebuild --library 'libncurses' -- -pv --exclude ncurses

This command will print a list of ebuilds to be rebuilt. Examine it and if it is ok, let portage rebuild the listed ebuilds:

#  revdep-rebuild --library 'libncurses' -- --exclude ncurses
Upon perl-5.24 update, it is required to run a special tool called perl-cleaner. This will rebuild many perl-related modules, etc.

#  perl-cleaner --all