Changes

Jump to: navigation, search

Ruby-kit

412 bytes added, 6 months ago
The Problem Being Solved
This way, we can set Ruby 2.6 as our "baseline", or "compatibility" version that our minimum supported version in Funtoo ebuilds. Ensuring everything works with 2.6 should not be tremendously hard,
and we can move to 2.6 without changing every single ebuild that only references a 2.5 or earlier Ruby version. 2.7 is our "preferred" version -- and will be used if an ebuild supports it. But manyebuilds are missing {{c|ruby27}} in {{c|USE_RUBY}}. They may work fine with Ruby 2.7 and simply need to be updated to reflect this, or they may not. I view this as a bit more of a stretch at thistime as compared to 2.6, so I did not select Ruby 2.7 as our "compatibility" version, although I would have preferred to do this.
These masking changes also have an interesting side-effect where we can make Ruby 3.0 available for developers, but Ruby-using packages will not actually depend on Ruby 3.0, ''even if they reference
Bureaucrats, Administrators, wiki-admins, wiki-staff
6,609
edits

Navigation menu