Jump to: navigation, search


53 bytes added, 9 months ago
The Problem Being Solved
and we can move to 2.6 without changing every single ebuild that only references a 2.5 or earlier Ruby version. 2.7 is our "preferred" version -- and will be used if an ebuild supports it. But many
ebuilds are missing {{c|ruby27}} in {{c|USE_RUBY}}. They may work fine with Ruby 2.7 and simply need to be updated to reflect this, or they may not. I view this as a bit more of a stretch at this
time as compared to 2.6, so I did not select Ruby 2.7 as our "compatibility" version, although I would have preferred to do this. Ebuilds still need to "opt in" to Ruby 2.7+ support.
These masking changes also have an interesting side-effect where we can make Ruby 3.0 available for developers, but Ruby-using packages will not actually depend on Ruby 3.0, ''even if they reference
Bureaucrats, Administrators, wiki-admins, wiki-staff

Navigation menu