Changes

Jump to: navigation, search

Package:Apache

1,868 bytes removed, 6 years ago
Removed table of USE flags, as this is going to be added by an update Daniel is working on.
== Install ==
=== Configure USE Flags ==={| class="wikitable" style="margin: 1em auto;" width=80%! width="20%" | Use flag! width="10%" | Default! width="10%" | Recommended! width="60%" | Description|-| style="text-align: center;" | debug| style="text-align: center;" | No| style="text-align: center; background-color: red;" | No| style="text-align: center;" | Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see http://www.gentoo.org/proj/en/qa/backtraces.xml.|-| style="text-align: center;" | doc| style="text-align: center;" | No| style="text-align: center;" | | style="text-align: center;" | Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally|-| style="text-align: center;" | ldap| style="text-align: center;" | No| style="text-align: center;" || style="text-align: center;" | Add LDAP support (Lightweight Directory Access Protocol).|-| style="text-align: center;" | selinux| style="text-align: center;" | No| style="text-align: center; background-color: yellow" | No, unless selected by default.| style="text-align: center;" | !!internal use only!! Security Enhanced Linux support, this must be set by the selinux profile or breakage will occur|-| style="text-align: center;" | ssl| style="text-align: center;" | Yes| style="text-align: center;" || style="text-align: center;" | Add support for Secure Socket Layer connections.|-| style="text-align: center;" | static| style="text-align: center;" | No| style="text-align: center;" || style="text-align: center;" | !!do not set this during bootstrap!! Causes binaries to be statically linked instead of dynamically.|-| style="text-align: center;" | threads| style="text-align: center;" | No| style="text-align: center;" || style="text-align: center;" | Add threads support for various packages. Usually pthreads.|} 
If you want to enable any of the above use flags, create a file called <tt>/etc/portage/package.use/apache</tt> and add the options that you want to enable to it. For example:
{{file|name=/etc/portage/package.use/apache|desc= |body=
wiki-moderators
504
edits

Navigation menu