Open main menu

Funtoo β

Changes

Virtual Packages

136 bytes added, 5 years ago
When virtual packages can be used?: clarify on binary compatibility
# the virtual providers must be interchangeable at runtime with no consequences to the reverse dependencies. In other words, installing another provider and removing the currently used provider must not cause any breakage or require reverse dependencies to be rebuilt.
# Reverse dependencies need to have consistent, predictable requirements for the alternatives. In other words, the packages must not require a very specific versions of the alternatives.
 
Virtuals can not be used if the underlying packages don't provide binary compatibility at least between predictable range of versions.
wiki-staff
51
edits