Difference between revisions of "Talk:ZFS as Root Filesystem"

From Funtoo
Jump to: navigation, search
m
(Issues on the latest ZFS Install Guide instructions)
Line 1: Line 1:
The .iso files will not install on to a USB Stick.  When extracting there appears to be a name not compatible with FAT32 sticks, resulting in error -1009 'can not extract'.
+
A few points regarding the new instructions of the "ZFS Install Guide":
  
I'll check .iso USB creation
+
- using the suggested ubuntu version, and after adding enabling the universe repository sources, poses a (minor) problem when trying to update. The proble and the solution described at http://askubuntu.com/q/761592/48282.
Oleg.
 
  
This is under re-write progress and will use only genkernel based installs as it officially shipped by Funtoo. All alternative ways are very much supported and appreciated  but should be in their corresponding pages to make guides modular. Keeping 3-4 alternatives in one guide often leads to uncertain results.
+
- `grub-install /dev/disk/by-id/ata-...` failed for me initially. The newly created partition, after `sgdisk -a1 -n2:48:2047 -t2:EF02 -c2:"BIOS boot partition" /dev/disk/by-id/ata-...`, was not present under `/dev/` as `sda2`. The "fix" was
Oleg.
+
  1. re-read the partition table without rebooting, i.e. `partx -u /dev/sda`.
 +
  2. re-emerge grub to support for i386_pc -- if I remember well... `USE="i386_pc" emerge -av grub`.
  
Cross-referenced ZFS Fun with this guide and vice versa.  -- 404
+
- Although all of the rest seem(ed) to be ok (ie  GRUB 2 support for ZFS, verification of existence of `/boot/grub/i386-pc/zfs.mod`), trying to (re-)boot, fails at the step of importing the zpool.  The zpool failed, initially to be exported. I re-booted the live USB stick, chrooted all the way from the scratch, exited, exported the zpool successfully. Still no success to boot.
 
 
2015-05-12 gkn: So, I have spent some days of nightmares ;-) trying to install funtoo on zfs. I was so keen that I documented the basic steps. It may be still improved, as I am not for 100% sure of the order and some minor configuration issues ...
 

Revision as of 20:51, October 23, 2016

A few points regarding the new instructions of the "ZFS Install Guide":

- using the suggested ubuntu version, and after adding enabling the universe repository sources, poses a (minor) problem when trying to update. The proble and the solution described at http://askubuntu.com/q/761592/48282.

- `grub-install /dev/disk/by-id/ata-...` failed for me initially. The newly created partition, after `sgdisk -a1 -n2:48:2047 -t2:EF02 -c2:"BIOS boot partition" /dev/disk/by-id/ata-...`, was not present under `/dev/` as `sda2`. The "fix" was

 1. re-read the partition table without rebooting, i.e. `partx -u /dev/sda`.
 2. re-emerge grub to support for i386_pc -- if I remember well... `USE="i386_pc" emerge -av grub`.

- Although all of the rest seem(ed) to be ok (ie GRUB 2 support for ZFS, verification of existence of `/boot/grub/i386-pc/zfs.mod`), trying to (re-)boot, fails at the step of importing the zpool. The zpool failed, initially to be exported. I re-booted the live USB stick, chrooted all the way from the scratch, exited, exported the zpool successfully. Still no success to boot.