Difference between revisions of "Talk:ZFS as Root Filesystem"

From Funtoo
Jump to: navigation, search
m
Line 1: Line 1:
A few points regarding the new instructions of the "ZFS Install Guide":
+
== LUKS? ==
 +
See http://forums.funtoo.org/topic/41-pure-uefi-luks-zfs/?p=5200 --[[User:Nikosalexandris|Nikosalexandris]] ([[User talk:Nikosalexandris|talk]]) 15:07, November 26, 2016 (UTC)
 +
 
 +
==  Comments on the Installation Guide ==
 +
A few points regarding the new instructions of the "ZFS Install Guide" (by [[User:Nikosalexandris|Nikos Alexandris]]):
  
 
- using the suggested ubuntu version, and after adding enabling the universe repository sources, poses a (minor) problem when trying to update. The proble and the solution described at http://askubuntu.com/q/761592/48282.
 
- using the suggested ubuntu version, and after adding enabling the universe repository sources, poses a (minor) problem when trying to update. The proble and the solution described at http://askubuntu.com/q/761592/48282.
Line 11: Line 15:
 
- Although all of the rest seem(ed) to be ok (ie  GRUB 2 support for ZFS, verification of existence of `/boot/grub/i386-pc/zfs.mod`), trying to (re-)boot, fails at the step of importing the zpool.  The zpool failed, initially to be exported. I re-booted the live USB stick, chrooted all the way from the scratch, exited, exported the zpool successfully. Still no success to boot.
 
- Although all of the rest seem(ed) to be ok (ie  GRUB 2 support for ZFS, verification of existence of `/boot/grub/i386-pc/zfs.mod`), trying to (re-)boot, fails at the step of importing the zpool.  The zpool failed, initially to be exported. I re-booted the live USB stick, chrooted all the way from the scratch, exited, exported the zpool successfully. Still no success to boot.
 
* Have you seen http://www.funtoo.org/index.php?title=ZFS_Install_Guide#Will_not_mount_on_first_reboot.3F ? This may help you find what went wrong. [[User:Tassietux|Tassietux]] ([[User talk:Tassietux|talk]]) 11:23, November 2, 2016 (UTC)
 
* Have you seen http://www.funtoo.org/index.php?title=ZFS_Install_Guide#Will_not_mount_on_first_reboot.3F ? This may help you find what went wrong. [[User:Tassietux|Tassietux]] ([[User talk:Tassietux|talk]]) 11:23, November 2, 2016 (UTC)
 +
 +
* Problem resolved, I guess something to do with re-compiling the ZFS modules. --[[User:Nikosalexandris|Nikosalexandris]] ([[User talk:Nikosalexandris|talk]]) 15:07, November 26, 2016 (UTC)

Revision as of 15:07, November 26, 2016

LUKS?

See http://forums.funtoo.org/topic/41-pure-uefi-luks-zfs/?p=5200 --Nikosalexandris (talk) 15:07, November 26, 2016 (UTC)

Comments on the Installation Guide

A few points regarding the new instructions of the "ZFS Install Guide" (by Nikos Alexandris):

- using the suggested ubuntu version, and after adding enabling the universe repository sources, poses a (minor) problem when trying to update. The proble and the solution described at http://askubuntu.com/q/761592/48282.

  • Added to Troubleshooting. Tassietux (talk) 11:23, November 2, 2016 (UTC)

- `grub-install /dev/disk/by-id/ata-...` failed for me initially. The newly created partition, after `sgdisk -a1 -n2:48:2047 -t2:EF02 -c2:"BIOS boot partition" /dev/disk/by-id/ata-...`, was not present under `/dev/` as `sda2`. The "fix" was 1. re-read the partition table without rebooting, i.e. `partx -u /dev/sda`. 2. re-emerge grub to support for i386_pc -- if I remember well... `USE="i386_pc" emerge -av grub`.

  • partx -u /dev/sda added to guide. Tassietux (talk) 11:23, November 2, 2016 (UTC)

- Although all of the rest seem(ed) to be ok (ie GRUB 2 support for ZFS, verification of existence of `/boot/grub/i386-pc/zfs.mod`), trying to (re-)boot, fails at the step of importing the zpool. The zpool failed, initially to be exported. I re-booted the live USB stick, chrooted all the way from the scratch, exited, exported the zpool successfully. Still no success to boot.

  • Problem resolved, I guess something to do with re-compiling the ZFS modules. --Nikosalexandris (talk) 15:07, November 26, 2016 (UTC)