User:Ben/FuntooServer UEFI LUKS RAID1

From Funtoo
< User:Ben
Revision as of 14:15, July 30, 2021 by Ben (talk | contribs)
Jump to: navigation, search

This is a quick write up on how I installed an encrypted Funtoo Server on my OVH Server

Special Thanks To:

Open TODOs

  • storage raid will currently not be decrypted and mounted automatically.

Assumptions

You will have an Ryzen/Epyc Server with:

  • 2x NVMe SSDs
  • 2+ Storage Disks

Target Setup

NAME            MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda               8:0    0   3.6T  0 disk  
└─sda1            8:1    0   3.6T  0 part  
  └─md127         9:127  0   3.6T  0 raid1 
    └─home      254:3    0   3.6T  0 crypt /home
sdb               8:16   0   3.6T  0 disk  
└─sdb1            8:17   0   3.6T  0 part  
  └─md127         9:127  0   3.6T  0 raid1 
    └─home      254:3    0   3.6T  0 crypt /home
nvme1n1         259:0    0 894.3G  0 disk  
├─nvme1n1p1     259:1    0   512M  0 part  
└─nvme1n1p2     259:2    0 893.8G  0 part  
  └─md126         9:126  0 893.6G  0 raid1 
    └─root      254:0    0 893.6G  0 crypt 
      ├─vg-swap 254:1    0    64G  0 lvm   [SWAP]
      └─vg-root 254:2    0 829.6G  0 lvm   /
nvme0n1         259:3    0 894.3G  0 disk  
├─nvme0n1p1     259:4    0   512M  0 part  
└─nvme0n1p2     259:5    0 893.8G  0 part  
  └─md126         9:126  0 893.6G  0 raid1 
    └─root      254:0    0 893.6G  0 crypt 
      ├─vg-swap 254:1    0    64G  0 lvm   [SWAP]
      └─vg-root 254:2    0 829.6G  0 lvm   /