Difference between pages "FLOP:Foreign language support" and "Package:Sublime Text Editor"

(Difference between pages)
 
 
Line 1: Line 1:
{{FLOP
+
{{Ebuild
|Created on=2014/02/20
+
|Summary=Sublime Text is an advanced commercial text editor.
|Summary=As suggested by Duncan Britton, here is a wiki page about a request for supporting foreign languages.
+
|CatPkg=app-editors/sublime-text
|Author=Aramis qc,
+
|Maintainer=Oleg,
|Maintainer=Aramis qc,
+
|Homepage=http://sublimetext.com
|FLOP Status=Implemented
+
|Reference Bug=FL-1097
+
 
}}
 
}}
== Overview ==
+
Sublime Text is a very complete text editor with lots of features, and support for plugins. It's free, but often shows a popup showing that's unregistered, so you can purchase the license for USD$70.
As suggested by [http://bugs.funtoo.org/browse/FL-1097 Duncan Britton] here is a wiki page about a request for supporting foreign languages.
+
  
== Proposal ==
+
== Install ==
Back into 2004 a group of people living in Quebec City started Gentoo-Québec. Those guys published a lot of documentation about Gentoo. Documents were in French and created with Latex. Some years later, let's say around 2009, they were converted to MediaWiki.
+
First, you must have installed [[Package:Layman|Layman]] with Git support. Then, add the overlay ''sublime-text'':
A new group was created in 2010. It was Funtoo-Québec and a new French wiki was born. Now in 2014 it turns to be more and more difficult to maintain its accuracy. People have less free time.
+
That is why this issue is a request for supporting foreign languages in official wiki. That could be done like Gentoo wiki does. When a version of a page is available in a foreign language, a link is active in the header. Example :
+
  
*/Funtoo_Linux_Installation/en (original English wiki)
+
<console>###i## layman -a sublime-text</console>
*/Funtoo_Linux_Installation/fr (French version)
+
*/Funtoo_Linux_Installation/de (German version)
+
  
...and so on...
+
Now, install the version you want. For the version 2:
 +
<console>###i## emerge -av sublime-text:2</console>
  
== Goal ==
+
For the version 3 (default):
Thus it could be easier to provide documentation in different languages.Members only have to translate in their language and the administrator adds the foreign version when ready.
+
<console>###i## emerge -av sublime-text:3</console>
  
== Objective ==
+
You can have installed both versions, so you must install it with the USE flag ''multislot'', that also brings the package eselect-sublime.
Improve the Funtoo wiki by adding support for foreign languages.
+
{{EbuildFooter}}
 
+
== History ==
+
 
+
'''December 2014'''
+
 
+
Daniel had foreign language support.
+
 
+
Funtoo Installation guide can now be translated to other languages.
+
 
+
Guy Fontaine (aka aramisqc) has started French translation of Funtoo Install guide.
+
 
+
[[Category:Wiki Development]]
+
{{FLOPFooter}}
+

Latest revision as of 04:52, January 3, 2015

app-editors/sublime-text


Current Maintainer(s):Oleg Vinichenko
Source Repository:Repository:Funtoo Overlay

http://sublimetext.com

Summary: Sublime Text is an advanced commercial text editor.


News

Drobbins

Perl Updates

Gentoo has bumped perl from 5.20 to 5.22. Be sure to run perl-cleaner --all after the upgrade.
2015-07-25 by Drobbins
Drobbins

ARM Rebuild

ARM systems will use new stage3's that are not compatible with earlier versions.
2015-06-27 by Drobbins
Drobbins

ABI X86 64 and 32

Funtoo Linux has new 32-bit compatibility libraries inherited from Gentoo. Learn about them here.
2015-06-18 by Drobbins
More...

Sublime Text Editor

Tip

We welcome improvements to this page. To edit this page, Create a Funtoo account. Then log in and then click here to edit this page. See our editing guidelines to becoming a wiki-editing pro.

Sublime Text is a very complete text editor with lots of features, and support for plugins. It's free, but often shows a popup showing that's unregistered, so you can purchase the license for USD$70.

Install

First, you must have installed Layman with Git support. Then, add the overlay sublime-text:

# layman -a sublime-text

Now, install the version you want. For the version 2:

# emerge -av sublime-text:2

For the version 3 (default):

# emerge -av sublime-text:3

You can have installed both versions, so you must install it with the USE flag multislot, that also brings the package eselect-sublime.