Difference between revisions of "Package:Sublime Text Editor"

 
Line 2: Line 2:
 
|Summary=Sublime Text is an advanced commercial text editor.
 
|Summary=Sublime Text is an advanced commercial text editor.
 
|CatPkg=app-editors/sublime-text
 
|CatPkg=app-editors/sublime-text
|Maintainer=Oleg,  
+
|Maintainer=Oleg,
|Repository=Funtoo Overlay
+
|Homepage=http://sublimetext.com
 
}}
 
}}
 +
Sublime Text is a very complete text editor with lots of features, and support for plugins. It's free, but often shows a popup showing that's unregistered, so you can purchase the license for USD$70.
  
{{PageNeedsUpdates}}
+
== Install ==
 +
First, you must have installed [[Package:Layman|Layman]] with Git support. Then, add the overlay ''sublime-text'':
 +
 
 +
<console>###i## layman -a sublime-text</console>
 +
 
 +
Now, install the version you want. For the version 2:
 +
<console>###i## emerge -av sublime-text:2</console>
 +
 
 +
For the version 3 (default):
 +
<console>###i## emerge -av sublime-text:3</console>
 +
 
 +
You can have installed both versions, so you must install it with the USE flag ''multislot'', that also brings the package eselect-sublime.
 
{{EbuildFooter}}
 
{{EbuildFooter}}

Latest revision as of 04:52, January 3, 2015

app-editors/sublime-text


Current Maintainer(s):Oleg Vinichenko
Source Repository:Repository:Funtoo Overlay

http://sublimetext.com

Summary: Sublime Text is an advanced commercial text editor.

News

Oleg

PHP and Kernel Updates

PHP and Kernel Updates
2016-04-01 by Oleg
Oleg

OpenSSL Update

OpenSSL Update
2016-03-04 by Oleg
Oleg

Python Updates

Python Updates
2016-02-12 by Oleg
More...

Sublime Text Editor

Tip

We welcome improvements to this page. To edit this page, Create a Funtoo account. Then log in and then click here to edit this page. See our editing guidelines to becoming a wiki-editing pro.

Sublime Text is a very complete text editor with lots of features, and support for plugins. It's free, but often shows a popup showing that's unregistered, so you can purchase the license for USD$70.

Install

First, you must have installed Layman with Git support. Then, add the overlay sublime-text:

# layman -a sublime-text

Now, install the version you want. For the version 2:

# emerge -av sublime-text:2

For the version 3 (default):

# emerge -av sublime-text:3

You can have installed both versions, so you must install it with the USE flag multislot, that also brings the package eselect-sublime.