Difference between revisions of "Funtoo:KDE"

From Funtoo
Jump to navigation Jump to search
m (adding summary KDE external link)
 
(2 intermediate revisions by the same user not shown)
Line 12: Line 12:
}}
}}
}}
}}
KDE is a new project to upgrade all the kde-kit packages to the latest version of [https://en.wikipedia.org/wiki/KDE_Plasma_5 KDE Plasma], integrate Funtoo metatools into kde-kit, and eventually bring the KDE to a "Grade A" Funtoo support Desktop Environment.
KDE is a new project to upgrade all the kde-kit packages to the latest version of [https://en.wikipedia.org/wiki/KDE_Plasma_5 KDE Plasma], integrate Funtoo metatools into kde-kit, and eventually bring the KDE to a "Grade A" Funtoo support Desktop Environment.


Line 20: Line 19:


# We have a Funtoo Project tracking the development with an active maintainer for the Desktop Environment
# We have a Funtoo Project tracking the development with an active maintainer for the Desktop Environment
# There is an official Funtoo kit dedicated to the Desktop Environment container all Funtoo Metatools powered packages
# There is an official Funtoo kit dedicated to the Desktop Environment containing all Funtoo Metatools powered packages
# There is an official [[Install/Download_and_Extract_Stage3|Stage 3 available]] to all Funtoo Users for the Desktop Environment
# There is an official [[Install/Download_and_Extract_Stage3|Stage 3 available]] to all Funtoo Users for the Desktop Environment


Line 27: Line 26:
Grade A support of the [https://en.wikipedia.org/wiki/KDE K Desktop Environment's (KDE)] on Funtoo Linux
Grade A support of the [https://en.wikipedia.org/wiki/KDE K Desktop Environment's (KDE)] on Funtoo Linux


== Funtoo Linux Python Support for KDE  ==
Python2:
Thanks to Siris's testing prompt, we were able to identify a python2 dependency when installing the kde-plasma-5 mix-in.
dev-qt/qtnetwork-5.15.2-r1 depends on net-libs/libproxy-0.4.18, which depends on dev-lang/spidermonkey:68, which contains BDEPEND="dev-lang/python:2.7
Python3:
TBC
{{ProjectFooter}}
{{ProjectFooter}}

Latest revision as of 14:56, August 10, 2022

   Summary
KDE is a new project to upgrade all the kde-kit packages to the latest version of KDE, integrate Funtoo metatools into kde-kit, and eventually bring the KDE to a "Grade A" Funtoo support Desktop Environment.
   Subpages
   People
Leads
  • R0b

Contributors
   Latest Status

KDE 5.24 is now live in the Funtoo next-release and available to beta testing for Funtoo next users.

05 July 2022

KDE is a new project to upgrade all the kde-kit packages to the latest version of KDE Plasma, integrate Funtoo metatools into kde-kit, and eventually bring the KDE to a "Grade A" Funtoo support Desktop Environment.

What are the Benefits?

This is part of a large collaborative community effort to bring the best in class and latest Desktop Environments to Funtoo Linux powered by Funtoo Metatools to ensure we have Grade A Funtoo Support Matrix for this DE. This means that the DE has reached three major milestones:

  1. We have a Funtoo Project tracking the development with an active maintainer for the Desktop Environment
  2. There is an official Funtoo kit dedicated to the Desktop Environment containing all Funtoo Metatools powered packages
  3. There is an official Stage 3 available to all Funtoo Users for the Desktop Environment

What are we Building?

Grade A support of the K Desktop Environment's (KDE) on Funtoo Linux

Funtoo Linux Python Support for KDE

Python2:

Thanks to Siris's testing prompt, we were able to identify a python2 dependency when installing the kde-plasma-5 mix-in.

dev-qt/qtnetwork-5.15.2-r1 depends on net-libs/libproxy-0.4.18, which depends on dev-lang/spidermonkey:68, which contains BDEPEND="dev-lang/python:2.7

Python3:

TBC