Funtoo:Programming Languages/Ruby

From Funtoo
< Funtoo:Programming Languages
Revision as of 06:21, March 18, 2022 by Siris (talk | contribs) (Escaping pipes in code blocks)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

About

Welcome to the official component of the Funtoo Programming Languages Project dedicated to the Ruby Programming Language.

This aspect of the Funtoo Programming Languages Project will track the efforts to modernize the Ruby Programming Language on Funtoo Linux.

Mission

What better way to define the mission of this Project than to do it Ruby:

   funtoo_ruby.rb (Ruby source code) - Funtoo Ruby project in Ruby
#!/usr/bin/env ruby
# frozen_string_literal: true

require 'date'

# Funtoo Ruby Project
class FuntooRuby
  def initialize
    @date = DateTime.now
    @release = 'next'
    @delimiter = '------------------------------'
  end

  def start
    puts "The Funtoo Programming Languages Project for the Ruby Programming language starts now: #{@date}"
    puts @delimiter
  end

  def release
    puts "Funtoo Ruby Project Funtoo release target: #{@release}"
    puts @delimiter
  end

  def mission
    puts 'Project Mission:'
    puts '1. Convert all Funtoo ruby-kit packages into funtoo-metatools autogenerated ebuilds including core language and Ruby'
    puts '2. Ensure at least two stable and latest Ruby versions are supported in the Funtoo Portage Tree: 2.7.5 and 3.1.1'
  end

  def take_action(method_name)
    send(method_name)
  end
end

Project = FuntooRuby.new

%w[start release mission].each do |action|
  Project.take_action(action.to_s)
end

Now let's get this Project started and have some fun with Ruby:

funtoo-ruby # ./funtoo_ruby.rb
The Funtoo Programming Languages Project for the Ruby Programming language starts now: 2022-03-05T23:20:19-08:00
------------------------------
Funtoo Ruby Project Funtoo release target: next
------------------------------
Project Mission:
1. Convert all Funtoo ruby-kit packages into funtoo-metatools autogenerated ebuilds including core language and Ruby
2. Ensure at least two stable and latest Ruby versions are supported in the Funtoo Portage Tree: 2.7.5 and 3.1.1

Reference

Some internal and external references that are critical for this project: