FLOP:Improve mesa handling

From Funtoo
Revision as of 00:31, May 17, 2018 by Temptorsent (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
Created on
2018/05/16
Original Author(s)
TemptorSent
Status

Funtoo Linux Optimization Proposal: Improve mesa handling

Improve handling of mesa and related packages to allow installation of multiple versions concurrently and selection between them. Create mesa-kit with one or more branches (-prime, -beta, -dev, -bleed) for each version in the tree.

---

Currently, mesa is not slotted and it installs links to drivers in locations that conflict with some vendor drivers (amdgpu-pro, specifically).

To make managing mesa versions cleaner, I propose we extend the current eselect-mesa tool (or create a new tool) to also manage links across versions, not just drivers.

Conflicts appear to occur in:

/usr/lib{32,64}/dri

which currently contains symbolic links to the actual .so drivers in ../mesa -- adjusting this link and setting proper library paths should be most of the work needed.

To prevent breakage for existing users while these changes are in the experimental phase, and to allow explicit selection of which mesa versions are provided, mesa and it's immediate dependencies (libdrm, others?) and tools (eselect-mesa) should be moved to its own kit with one or more (old, stable, dev) branches for each major.minor version, such as:

13.0-old, 17.0-prime, 17.1-old, 17.2-prime, 18.0-beta, 18.0-dev, 18.1-alpha, 18.1-dev

or some such similar scheme -- we may want to create -old branches for all versions so we can keep only the most recent version or two in the active branches.